Sign up for The Wire Newsletter!

2010 Hino 258 rollback A/C, Radio? Issue, please help. Truck down

Discussion in 'Hino Trucks' started by roadmasterstowing, Jul 12, 2018.

  1. roadmasterstowing

    roadmasterstowing New Recruit Owner/Operator

    Joined:
    Jul 11, 2018
    Messages:
    1
    Trophy Points:
    1
    Ratings:
    +0 / 0 / -0
    Hello
    I have a hino 258 rollback. Truck has 282k on it. While cleaning and doing PM the other day, my driver noticed that the blower motor was really low, he tapped it a few times, and it went back to normal. Then it stopped. Brought the truck to the shop, and the techs replaced blower motor, and now the blower motor is running at correct speed, but no cold air coming out. Switch works, the ac light button is on, and they found that the aftermarket radio is dead. Any ideas?????
     
  2. greasytshirt
    Dr Pepper Addict

    greasytshirt Moderator Staff Member Mechanic

    Joined:
    Dec 3, 2013
    Messages:
    2,140
    Trophy Points:
    200
    Ratings:
    +716 / 0 / -0
    What year is the truck?

    The AC switches are known to burn out, taking out it's connector and wires at the same time.

    Check both the radio fuse and the room light fuse. Oddly enough, the room light fuse partially powers both the radio and the AC compressor. For a 2008 truck anyway. I'm taking a shot in the dark on the year.
     
    Last edited: Jul 15, 2018
    • Treadmill
      Caffeine Fix

      Treadmill Veteran Expediter Owner/Operator

      Joined:
      Jan 1, 2008
      Messages:
      2,286
      Trophy Points:
      430
      Ratings:
      +3,290 / 7 / -1
      Carrier:
      Load One
      Vehicle:
      2017 Sprinter
      Going by the title of the thread, I believe his truck is a 2010.
       
      • Zing! Zing! x 1
    • greasytshirt
      Dr Pepper Addict

      greasytshirt Moderator Staff Member Mechanic

      Joined:
      Dec 3, 2013
      Messages:
      2,140
      Trophy Points:
      200
      Ratings:
      +716 / 0 / -0
      I missed that completely.
       
    • Andyinchville1

      Andyinchville1 Active Expediter Owner/Operator

      Joined:
      Apr 21, 2016
      Messages:
      91
      Trophy Points:
      30
      Ratings:
      +17 / 1 / -0
      No AC? NO radio? ....Truck is STILL functional ....
      Go out and make some $$ and tell your helper you won't them charge extra for the free sauna !

      OR

      You could be nice and check the refrigerant level (if it's not properly charged or leaked out), the blower will work but the AC compressor won't turn on to make things cool...

      Good luck.
       
    • Techmaster

      Techmaster New Recruit Mechanic

      Joined:
      Aug 3, 2018
      Messages:
      21
      Trophy Points:
      3
      Ratings:
      +3 / 0 / -0
      Also the actuator that controls the temperature blend door could be jammed or dead, turn the key on, fan to level 1, turn the temp from cold to hot and carefully try to listen if you can hear the motor moving or clicking if jammed up
       
    • Hino123

      Hino123 Active Expediter Researching

      Joined:
      Dec 26, 2016
      Messages:
      92
      Trophy Points:
      30
      Ratings:
      +31 / 0 / -0
      Hino trucks actually do NOT use an actuator for the blend or mode doors. Its just a cable operated setup. The heat and mode selector should move freely from left to right. Is the cabin air filter plugged? Is the A/C belt loose or even there?. Did the a/c work before this happened?.
       
    Loading...

    Share This Page