Load One 2021

RoadTime

Veteran Expediter
Owner/Operator
Offline
Ahh, I remember this happened in my old sprinter once, but that time it restarted. Still don’t remember the cause.


Sent from my iPhone using EO Forums
 

Turtle

Administrator
Staff member
Owner/Operator
Offline
Recently mine shut down while driving. Fuel pump just up and died.
 

RoadTime

Veteran Expediter
Owner/Operator
Offline
Recently mine shut down while driving. Fuel pump just up and died.

Would it try to start if you turned the key on?

That would suck if that’s it. I just had the fuel pump replaced...I think that’s what it was What ever it was, it wasn’t cheap. But I’m going to guess in my non-mechanical mind, it’s something else since it does absolutely nothing when you turn the key, other then turn the electrical on. But what do I know,...oh yeah, just about nothing


Sent from my iPhone using EO Forums
 

RoadTime

Veteran Expediter
Owner/Operator
Offline
Currently diagnosing...ran the codes, sounds like they are looking for a broken or corroded ground wire, should know more around noon...I hope


Sent from my iPhone using EO Forums
 
  • Like
Reactions: jelliott

RoadTime

Veteran Expediter
Owner/Operator
Offline
Ok, wrapping up my fun.
I almost made it 10 years at Load 1 without a breakdown while under-load. Close but no cigar.

After getting towed to Stoops Freightliner in New Haven, IN. The hot part of the load was transferred to another L1 driver for delivery in the morning.
Stoops 1 $printer Tech works days, and they lock up at midnight, so I had to get a motel for the night as I wasn’t able to stay on the property. After a return trip via Uber the waiting began...
Finally determined that the Front NOX sensor connector was melted and corroded causing a short. It was mentioned that water had got in. And it was raining all day. Seems like my sprinters have always acted up when it rains

Anyways, the connector and some melted wires were replaced and deemed safe. Although, the actual cause is still unknown. I’ll be following up with Wayne on that.

So off to Grand Rapids I went to deliver the remainder of the not-as-hot freight.

I got booked on a Friday morning extra short load (8 miles), afterwards having my week turn into break even at best, I just wanted to go home, so I did





IMG_6997.JPG


Sent from my iPhone using EO Forums
 
  • Like
Reactions: jelliott and Turtle

RoadTime

Veteran Expediter
Owner/Operator
Offline
While traveling across Michigan the other day as I approached the Albion exit off I-94, someone in the left lane decided at the last possible second to take the exit. It's something that I kind of look for because it happens so often. I'm pretty sure I was in his blind spot. His right rear wheel was even or just behind my left front wheel. But he shot over like I wasn't there. If I hadn't been paying attention he'd have clipped me and it would have been really bad.

But at it was, I steered to the right and he missed me, but I had no shot at negotiating the exit ramp curve. One of those 25 or 30 MPH curves. It's one of those exits where you exit to the right and stop at a road, then do a hairpin turn to the left and you're back on the on-ramp. I plowed right through the curve, taking out one of those signs with the big arrow on it to let you know there's a curve there. I sheered off the sign pole, and what was left sticking up out of the ground took out my oil pan. It took out the roof slope and the windshield, little bit of the hood. But the oil pan remains the wild card. If it's just the oil pan, not a big deal, but if it did some other damage to the engine, I dunno. The engine never shut off, though.

I wasn't injured at all. But imagine being showered with sawdust, a lot of it, only it's shattered glass.

But I had it towed to a body shop in town, one recommended by a couple of people at the gas station and a cop. So I'm hanging out in Albion. I should hear from the insurance adjuster soon.

View attachment 20594
Any updates?

Sent from my P00I using EO Forums mobile app
 

Turtle

Administrator
Staff member
Owner/Operator
Offline
Any updates?

Sent from my P00I using EO Forums mobile app
The insurance adjuster is, well, I don't want to say in public because it's not flattering. I called and left a voicemail every day, then got Matt to send an email to a higher-up. Finally the day after Memorial Day I got the phone calls returned. He said he'd send me an email with the stuff he needs from the body shop. An hour later, no email. I called and left another voicemail spelling out my email address. Nothing. Wed, Thus, Fri, called every day, nothing. Got Matt involved again. Another weekend. On Monday afternoon I get a call, give him my email again, and waited on the phone while he sent it. Got it.

Took it over to the body shop, gave them the information as well as forwarded the email to them.

So making progress, but the body shop still, after more than two weeks, has not yet done the estimate.
 
  • Wow
Reactions: RoadTime

RoadTime

Veteran Expediter
Owner/Operator
Offline
That's some run around.
Geez, the shop sure is taking their sweet time too. Is everybody on vacation :rolleyes:

waiting2.jpg
 
  • Like
Reactions: Turtle

jelliott

Veteran Expediter
Motor Carrier Executive
US Army
Offline
Probably like a lot of places.... cant get any workers..... terrible right now.
 

RoadTime

Veteran Expediter
Owner/Operator
Offline
Spent the night at the yard for a near by morning pick up.

1st time I’ve ventured upstairs to the lounge since the pandemic started.

Oh how I’ve missed the massage chair. Although, it wasn’t quite how I remembered

IMG_7043.JPG


Sent from my iPhone using EO Forums
 
  • Haha
Reactions: Turtle

jelliott

Veteran Expediter
Motor Carrier Executive
US Army
Offline
We have stated work on the new driver park. Landscaping, picnic tables and a big grill. Dog run will be coming in the spring. Please be extra cautious in the yard with workers out there. As well the new expanded parking area for vans and bobtails only is now open as well!
IMG_9779.JPG


Sent from my iPhone using EO Forums
 
Top