Sign up for The Wire Newsletter!

Hi no 268 no acceleration

Discussion in 'Hino Trucks' started by Kyle01888, Dec 21, 2017.

  1. Kyle01888

    Kyle01888 New Recruit Mechanic

    Joined:
    Dec 21, 2017
    Messages:
    1
    Trophy Points:
    1
    Ratings:
    +0 / 0 / -0
    Hi guys new to the forum. My shop has 22 Hino 268s from 2013 to 2017. I have a 2013 right now that has no acceleration from a dead stop but is fine after about 45 seconds or so and seems to wake up. Its fine going down the road and has plenty of power just not from a dead stop. Replaced the brake switch at the pedal for the hell of it and the fuel filter. Also checked the turbo end shaft play and seems tight. It regens fine and has no dash lights. Anyone else having a similar issue??
     
  2. greasytshirt
    Dr Pepper Addict

    greasytshirt Moderator Staff Member Mechanic

    Joined:
    Dec 3, 2013
    Messages:
    2,143
    Trophy Points:
    200
    Ratings:
    +717 / 0 / -0
    Is it an air brake truck? There's an air switch on the service brake relay valve, it gets moisture in it and will cause identical symptoms. This can be confirmed with DXII, look for disagreement between the brake switch and stop light switch.

    There are a couple switches down there. You'll be able to isolate the correct switch by unplugging one at a time, jumping the harness connector, test driving it, etc. When you isolate it, bring it with you to the dealer. They are hard to identify in the diagrams, so you may have to compare color of plastics, connector shapes, paint dots, stickers, etc.

    Sent from my XT1585 using EO Forums mobile app
     
    Last edited: Dec 21, 2017
    Loading...

    Share This Page